Перейти к содержимому


Фото

Компьютер не видит телефон...


  • Чтобы отвечать, сперва войдите на форум
3 ответов в теме

#1 Multook Опубликовано 28 Июнь 2014 - 11:22

Multook
  • Свои
  • 986 Сообщений:
  • Екатерина Алхазашвили

Друзья, у меня такая проблема:
раньше, когда у меня был телефон с Андроид 4.1, при подключении его через USB к компьютеру, он начинал заряжаться и предлагать подключить телефон, как USB-накопитель.
Теперь у меня телефон с Андроид 4.2.1 и при подключении его так же к компьютеру он начинает только заряжаться....
При этом кабель точно исправен (проверяли на папином телефоне (Андроид 4.1)).
Смотрели в интернете, у многих такая же проблема (телефон только заряжается и не подключается как USB-накопитель).

Это проблема телефона, или особенность интерфейса Андроид 4.2.1?
 



#2 Ripper Опубликовано 28 Июнь 2014 - 12:35

Ripper
  • Свои
  • 447 Сообщений:
  • Павел Рустанович
Ну, минута квалифицированного гуглинга :) с моей стороны принесла следующие варианты:
  • Поискать в настройках settings --> storage --> ... connectivity mode или нечто похожее и переключить его в режим mass storage (в переводе может быть какая-нибудь Передача Данных или тот же Накопитель).
  • Кто-то предлагает

    1. Connect your phone to a computer (The device will be connected in MTP mode as default)
    2. Reboot your phone while connected to the computer
    3. Wait until you see the USB icon on your Notification Bar
    4. You will now have an option to select Mass Storage henceforth

    Но это вроде ни у кого, кроме автора, не работает.
  • Вроде бы, самый надёжный вариант - включить Developer Mode, после чего устройство будет всегда подключаться в нужном режиме

    1. Go to Settings -> About Phone/Tablet.
    2. Go to “Build Number” at the end of the Scroll list.
    3. Tap on “Build Number” repeatedly (7 times). On your third tap you should see message indicating that you only have 4 more taps to go to ‘become a developer’. Keep tapping until you are a developer.

    О каких-либо негативных последствиях включения developer mode не знаю. В любом случае, его можно потом отключить.
Ну и ещё есть вариант поискать "mass storage enabler"-подобные приложения в магазине. Вполне может быть, что делают они в том числе и что-то недружественное, помимо необходимого.

ps: судя по всему, это особенность версии 4.2 и выше.

Изменено: Ripper, 28 Июнь 2014 - 12:49

post-2756-0-28658900-1472313042.png


#3 DNAlh Опубликовано 28 Июнь 2014 - 16:39

DNAlh
  • Борцы со злом
  • 44 104 Сообщений:
  • Дмитрий Алхазашвили

Попробовал все три варианта - ничего не помогло. :( В "Настройки" -> "Память" -> "Внешний USB-накопитель" есть "Подключить USB-накопитель", но этот подпункт серый, т.е. неактивный. По идее решение должно быть какое-то очевидное, но я не понимаю, где оно. Ау, андроидоводы! 

 

DN



#4 Денис Опубликовано 28 Июнь 2014 - 19:32

Денис
  • Genius loci
  • 6 509 Сообщений:
  • Денис Сумин

Во-первых, немного общей информации. Пишу по памяти, могу ошибаться, но надеюсь, что нет :)
Телефоны и вообще все устройства подключаются к компьютеру одним из двух образом: MSC (Mass Storage Device) или MTP (Media Transfer Protocol). Первый -- это как флешка. Второй -- это когда устройство определяется компьютером именно как устройство; при этом обычно есть возможность работать с файловой системой устройства и с другими настройками.
 
Так вот, насколько я помню, начиная с версии 4.0, из андроида было убрано подключение как флешка (MSC), и оставлено подключение только через протокол MTP. Реализация подключения-как-флешки осталась на производителях телефонов; еще её возможно достичь с помощью приложений из маркета (о чём писал Паша). Так, у меня в древней Sony Xperia настройки подключения телефона очень неочевидно скрыты в пункте меню Xperia, причем там можно выбрать подключение телефона-как-флешки.
 
По идее, любой андроид-телефон должен "по умолчанию" и "из коробки" работать в режиме MTP.
 
В интернете встречаются упоминания о том, что иногда по умолчанию отключена галка, включающая протокол MTP:
 

I had the same problem but I solved it a few seconds ago after reading a post on another forum. It seems like the MTP option somehow got unchecked (not by me!), maybe when installing the latest Android update…

Settings → Storage → ⋮ → USB-connection to computer → MTP media device ☑
Note that I run Android in Swedish, so the line above is only a translation from Swedish to English…

 

 
Где-то я еще видел путь по меню, что-то вроде: Settings -> Connectivity -> ...
 
В общем, надо попробовать найти эти самые настройки Connectivity.
 
А вот это, скорее всего, не то: 
 

Попробовал все три варианта - ничего не помогло. :( В "Настройки" -> "Память" -> "Внешний USB-накопитель" есть "Подключить USB-накопитель", но этот подпункт серый, т.е. неактивный.

 

Я думаю, что этот пункт меню про подключение накопителя (флешки) К телефону.

 

Что еще предложить посмотреть-продиагностировать удалённо, не знаю. Дальше я бы хотел сам посмотреть меню настроек и посмотреть, что видит компьютер (это я делал бы в линуксе, там можно видеть события, которые происходят при подключении устройств).






0 пользователей читают эту тему

0 пользователей, 0 гостей, 0 невидимых